Directus Cloud Dashboard Slow
Incident Report for
Directus
Resolved
This incident has been resolved.
Posted
Aug
21
,
2025
-
20:24
EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Aug
21
,
2025
-
17:39
EDT
Investigating
The Directus Cloud Dashboard is experiencing degraded performance.
- Core services remain operational
- Users may experience slower response times or intermittent connectivity issues with the Directus Cloud dashboard
We are actively monitoring the situation and working to restore complete performance. Expect an update within 2 hours.
Posted
Aug
21
,
2025
-
15:44
EDT
This incident affected: Dashboard.
×
Subscribe to Incident
Subscribe to updates for
Directus Cloud Dashboard Slow
via . You'll receive .