All Self Service projects in the US region have been fully restored and are operating normally. The underlying issue impacting regional performance has been mitigated, and systems are stable. We are continuing to monitor the environment closely to ensure ongoing stability.
Posted Aug 06, 2026 - 04:50 EDT
Investigating
We are currently investigating an issue affecting non-enterprise accounts in the North America region, which may cause temporary unavailability or offline status. Enterprise accounts and other regions are unaffected.
Our engineering team is actively working on a resolution. Next update in 30 minutes or as soon as we have more details.
Posted Aug 06, 2026 - 03:40 EDT
This incident affected: Directus Self Service Cloud (North America).