Project Provisioning Maintenance

Incident Report for Directus

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 16:10 EDT

Monitoring

Maintenance is complete and self-service cloud project provisioning has been restored. We're monitoring all systems to ensure continued stability.
Posted Jul 11, 2025 - 14:20 EDT

Identified

We're rolling out the final maintenance changes now and expect full service restoration within the next 30 minutes.

New cloud project provisioning will be available shortly.
Posted Jul 11, 2025 - 13:44 EDT

Investigating

We are currently performing scheduled maintenance on our cloud infrastructure to improve service reliability. During this time, provisioning of new self-service cloud projects has been temporarily disabled.

We expect to restore full service within the next 2-4 hours.
Posted Jul 11, 2025 - 11:55 EDT
This incident affected: Dashboard.