Investigating stability issues in the US region
Incident Report for
Directus
Resolved
This incident has been resolved.
Posted
Jul
22
,
2026
-
09:47
EDT
Monitoring
Service is returning to normal and we are continuing to monitor the situation closely
Posted
Jul
22
,
2026
-
08:51
EDT
Investigating
Our infrastructure provider is investigating node stability issues in the US region
Posted
Jul
22
,
2026
-
08:21
EDT
This incident affected: Directus Self Service Cloud (North America).
×
Subscribe to Incident
Subscribe to updates for
Investigating stability issues in the US region
via . You'll receive .