Directus Cloud API Down
Incident Report for
Directus
Resolved
This incident has been resolved.
Posted
Mar
13
,
2026
-
14:13
EDT
Investigating
We are aware of issues with the DIrectus Cloud Dashboard and the team is actively investigating.
Posted
Mar
13
,
2026
-
13:22
EDT
This incident affected: Dashboard.
×
Subscribe to Incident
Subscribe to updates for
Directus Cloud API Down
via . You'll receive .