Our monitoring indicates the underlying infrastructure issues have stabilized and we have re-enabled new project creation.
All systems are functioning normally and customers can now create new projects without restrictions. We will continue monitoring closely to ensure continued stability.
Posted Jul 17, 2025 - 21:20 EDT
Update
We continue to monitor the infrastructure issues affecting new project creation. New project creation remains temporarily disabled while we work with our infrastructure providers to ensure full resolution.
Posted Jul 17, 2025 - 16:37 EDT
Update
We continue to actively monitor the situation affecting new project creation. Our team is working to resolve the underlying issues.
Thank you for your continued patience.
Posted Jul 17, 2025 - 14:27 EDT
Investigating
We are currently experiencing delays with new project creation on Directus Cloud. To ensure a smooth experience for our users, we have temporarily disabled new project creation while we investigate and resolve the underlying issues. We will re-enable new project creation once we have confirmed the issue is fully resolved. Please expect an update within 2 hours.
- New Project Creation: Temporarily unavailable - Existing Projects: Fully operational and unaffected - All Other Services: Operating normally